Ferramenta de diagnóstico do DirectX

A documentação da Ferramenta de diagnóstico do Microsoft® DirectX® contém os seguintes tópicos:

  • Sobre a Ferramenta de diagnóstico do DirectX
  • O que procurar
  • Testando componentes do DirectX
  • Substituindo o comportamento padrão


Sobre a Ferramenta de diagnóstico do DirectX

A Ferramenta de diagnóstico do Microsoft® DirectX® fornece informações sobre componentes e drivers da interface de programação de aplicativo (API) do DirectX no sistema. Ela permite que você teste as saídas de sons e de elementos gráficos e os provedores de serviços do Microsoft DirectPlay®. Ela também permite que você desative alguns recursos de aceleração de hardware.

Você pode usar a ferramenta de diagnóstico para coletar informações a serem passadas para um técnico de suporte durante uma chamada e pode salvar as informações coletadas pela ferramenta e colá-las em um email.

As informações são apresentadas em várias páginas. Você pode se mover entre elas seguindo um destes métodos:

  • Clicar nas guias.
  • Clicar no botão Próxima página.
  • Pressionar as teclas SETA PARA A ESQUERDA ou SETA PARA A DIREITA quando o foco de entrada estiver em uma guia.

Você pode especificar como essa ferramenta exibirá as tabelas. Para isso, escolha a coluna pela qual deseja ordenar as linhas da tabela. Clique no botão do cabeçalho na parte superior dessa coluna e a tabela será ordenada de forma numérica ou alfabética com base os itens da coluna. Para reverter a ordem de classificação, clique no botão do cabeçalho novamente.

Você pode clicar no botão Salvar todas as informações para salvar todas as informações em um arquivo de texto.

Observação

  • Algumas informações, como o volume de memória em uma placa de vídeo, podem ser aproximadas.


O que procurar

Se houver problemas durante a execução dos aplicativos do Microsoft® DirectX®, a Ferramenta de diagnóstico do DirectX poderá ajudá-lo a encontrar a solução. Estes são alguns dos itens pelos quais você deve procurar:

  • Versões incorretas dos componentes do DirectX. Na seção Observações da página Arquivos do DirectX , procure os avisos sobre os arquivos Beta e de depuração. Os arquivos Beta são versões de teste anteriores e não devem ser instalados em aplicativos comerciais. As versões de depuração, que são usadas no desenvolvimento de programas e que também não devem ser instaladas com o produto final, podem tornar a execução dos aplicativos mais lenta do que quando são instalados com as versões comerciais dos componentes.
  • Falta de aceleração do hardware. Alguns programas são executados bem lentamente ou talvez nem sejam executados, a menos que as acelerações de hardware do Microsoft DirectDraw® ou do Direct3D® estejam disponíveis. Na página Vídeo, em Recursos do DirectX , verifique se as acelerações do DirectDraw, do Direct3D ou do AGP Texture estão marcadas como "Não disponíveis". Se estiverem, você deve pensar em atualizar o hardware.
  • Dispositivo não conectado. Se um joystick ou outro dispositivo de entrada não responder, é possível que ele não esteja configurado corretamente. Certifique-se de que o dispositivo aparece na página Entrada da Ferramenta de diagnóstico do DirectX. Se não aparecer, adicione o dispositivo usando o Painel de controle.
  • Drivers não assinados. A Microsoft não verificou se os drivers não assinados são totalmente compatíveis com a versão mais recente do DirectX. Esses drivers estão listados na página apropriada do componente.

Observação: se você usar os serviços de terminal para trabalhar em um sistema remoto que ofereça suporte à aceleração de hardware, a Ferramenta de diagnóstico do DirectX deve indicar esse suporte. No entanto, os serviços de terminal não podem usar a aceleração de hardware; portanto, o suporte não estará disponível.


Testando componentes do DirectX

Você pode testar o Microsoft® DirectDraw® e o Direct3D® em cada monitor conectado ao sistema. E também pode testar o DirectSound® em cada dispositivo de saída de som wave e o DirectMusic® em cada porta de música.

Para testar um recurso do DirectX: clique no botão Teste na página apropriada, leia qualquer mensagem exibida e observe ou escute os testes. Execute todos os testes até aparecer uma mensagem perguntando se o teste obteve êxito. Se a resposta for Não, nenhum outro teste será executado.

No caso do DirectMusic, só há um teste. Clique em OK para indicar se a música está sendo reproduzida corretamente ou não.

Você pode testar a funcionalidade do Microsoft DirectPlay® em qualquer provedor de serviços disponível.

Para testar o DirectPlay

  1. Na página Rede, clique em Testar DirectPlay. Na caixa de diálogo Teste do DirectPlay, digite um nome de usuário e escolha um provedor de serviços. Selecione Criar nova sessão e clique em OK. Se você escolheu uma conexão de modem, clique em Resposta na caixa de diálogo Conexão do modem para colocar o modem no modo de resposta automática.
  2. Agora execute a Ferramenta de diagnóstico do Microsoft DirectX® em outro computador que possa estabelecer a conexão selecionada com o primeiro computador. Clique em Testar DirectPlay, digite o nome de um outro usuário, escolha o mesmo provedor de serviços, clique no botão Juntar-se à sessão existente e, em seguida, clique em OK.

    Para alguns tipos de conexão, talvez seja necessário fornecer mais informações como, por exemplo, um número de telefone. Para uma conexão TCP/IP em uma rede local, você pode deixar a caixa de texto em branco.

  3. No segundo computador, selecione o nome da sessão na Lista de sessões que contiver o nome da sessão criada no primeiro computador e clique em OK.
  4. Os dois computadores devem mostrar agora uma caixa de diálogo de bate-papo. Digite uma mensagem na caixa de entrada de um dos computadores e clique em Enviar. A mensagem deve ser exibida na área de rolagem da caixa de diálogo de bate-papo dos dois computadores.


Substituindo o comportamento padrão

Na página Som, você pode definir um nível de aceleração de hardware diferente movendo o controle deslizante. Esse nível permanecerá ativado até o fechamento da Ferramenta de diagnóstico do Microsoft® DirectX®.

Você pode desativar a aceleração de hardware do Microsoft DirectDraw® ou do Direct3D® caso essa aceleração esteja disponível. Para isso, vá até a página Vídeo de cada dispositivo de vídeo e clique no botão Desativar. A aceleração de hardware ficará indisponível para os aplicativos, mesmo depois do fechamento da Ferramenta de diagnóstico do DirectX. Para reativá-la, clique no botão Ativar na página Vídeo apropriada.

Observação

  • A desativação da aceleração do DirectDraw também desativará a aceleração do Direct3D.

Você também pode substituir a taxa de atualização do monitor definida pelos aplicativos de tela inteira do DirectDraw. Só faça isso se você tiver problemas de exibição em um aplicativo e achar que o aplicativo está definindo uma taxa de atualização inválida.

Para definir uma taxa de atualização de substituição

  1. Na página Mais ajuda, clique no botão Substituir.
  2. Na caixa de diálogo Substituir comportamento de atualização do DirectDraw, selecione a caixa de edição e insira uma taxa de atualização válida para o monitor.

    A opção Substituir valor é automaticamente selecionada quando você realiza essa ação.

  3. Clique em OK.

Para cancelar a taxa de atualização de substituição e permitir que os aplicativos do DirectDraw definam sua própria taxa de atualização

  1. Na página Mais ajuda, clique no botão Substituir.
  2. Na caixa de diálogo Substituir o comportamento de atualização do DirectDraw, selecione o botão de opção Padrão e clique em OK.